Re: [edk2] EmulatorPkg broken

Subject: Re: [edk2] EmulatorPkg broken

From: Jordan Justen <jljusten@gmail.com>

To: "edk2-devel@lists.sourceforge.net" <edk2-devel@lists.sourceforge.net>

Date: 2014-05-22 02:04:16

On Wed, May 21, 2014 at 3:47 PM, Rafael Machado
 wrote:
> Hi everyone
>
> I just tried to compile the emulator package and got the following error:
>
> -----------------------------------------------------------------------------------------------------------------------
> Building ... /home/rafael/src/edk2/EmbeddedPkg/SerialDxe/SerialDxe.inf [X64]
> "/usr/bin/ld" -o
> /home/rafael/src/edk2/Build/Emulator/DEBUG_GCC46/X64/EmbeddedPkg/SerialDxe/SerialDxe/DEBUG/SerialDxe.dll
> -nostdlib -n -q --gc-sections
> --script=/home/rafael/src/edk2/BaseTools/Scripts/gcc4.4-ld-script --entry
> _ModuleEntryPoint -u _ModuleEntryPoint -Map
> /home/rafael/src/edk2/Build/Emulator/DEBUG_GCC46/X64/EmbeddedPkg/SerialDxe/SerialDxe/DEBUG/SerialDxe.map
> -melf_x86_64 --oformat=elf64-x86-64 -\(
> @/home/rafael/src/edk2/Build/Emulator/DEBUG_GCC46/X64/EmbeddedPkg/SerialDxe/SerialDxe/OUTPUT/static_library_files.lst
> -\)
> /home/rafael/src/edk2/Build/Emulator/DEBUG_GCC46/X64/EmbeddedPkg/SerialDxe/SerialDxe/OUTPUT/SerialDxe.lib(SerialIo.obj):
> In function `SerialSetAttributes':
> Building ...
> /home/rafael/src/edk2/MdeModulePkg/Universal/Console/TerminalDxe/TerminalDxe.inf
> [X64]
> /home/rafael/src/edk2/EmbeddedPkg/SerialDxe/SerialIo.c:168: undefined
> reference to `SerialPortSetAttributes'
> /home/rafael/src/edk2/Build/Emulator/DEBUG_GCC46/X64/EmbeddedPkg/SerialDxe/SerialDxe/OUTPUT/SerialDxe.lib(SerialIo.obj):
> In function `SerialSetControl':
> /home/rafael/src/edk2/EmbeddedPkg/SerialDxe/SerialIo.c:240: undefined
> reference to `SerialPortSetControl'
> /home/rafael/src/edk2/Build/Emulator/DEBUG_GCC46/X64/EmbeddedPkg/SerialDxe/SerialDxe/OUTPUT/SerialDxe.lib(SerialIo.obj):
> In function `SerialGetControl':
> /home/rafael/src/edk2/EmbeddedPkg/SerialDxe/SerialIo.c:261: undefined
> reference to `SerialPortGetControl'
> make: ***
> [/home/rafael/src/edk2/Build/Emulator/DEBUG_GCC46/X64/EmbeddedPkg/SerialDxe/SerialDxe/DEBUG/SerialDxe.dll]
> Error 1
>
>
> build.py...
>  : error 7000: Failed to execute command
> make tbuild
> [/home/rafael/src/edk2/Build/Emulator/DEBUG_GCC46/X64/EmbeddedPkg/SerialDxe/SerialDxe]
>
>
> build.py...
>  : error F002: Failed to build module
> /home/rafael/src/edk2/EmbeddedPkg/SerialDxe/SerialDxe.inf [X64, GCC46,
> DEBUG]
>
> - Failed -
> Build end time: 19:43:17, May.21 2014
> Build total time: 00:00:05
>
>
> ---------------------------------------------------------------------------------------------------------------------------------------------------------------------
>
> gcc version 4.6.4 (Ubuntu/Linaro 4.6.4-6ubuntu2)
> OS: Ubuntu 14.04 LTS

Are you using the current EDK II tree?

I think there was an issue with the EmbeddedPkg Serial dependency some
months back.

The current tree seems to build for me.

-Jordan

------------------------------------------------------------------------------
"Accelerate Dev Cycles with Automated Cross-Browser Testing - For FREE
Instantly run your Selenium tests across 300+ browser/OS combos.
Get unparalleled scalability from the best Selenium testing platform available
Simple to use. Nothing to install. Get started now for free."
http://p.sf.net/sfu/SauceLabs
_______________________________________________
edk2-devel mailing list
edk2-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/edk2-devel