[if !mso]> [if !mso]> [if gte mso 9]>

Re: [edk2] Can't load signed UEFI Option Rom when enable secure boot

Subject: Re: [edk2] Can't load signed UEFI Option Rom when enable secure boot

From: Zhaowei Qin <zwqin@marvell.com>

To: "edk2-devel@lists.sourceforge.net" <edk2-devel@lists.sourceforge.net>

Date: 2014-03-03 06:12:04

Hi Dong

 

Thanks for your quick response first!

1.       My EFIROM tool version is 0.1 Build 2549. Is that too old for building signed UEFI option rom?

2.       Can you help tell me where can I get the latest EfiRom tool?

3.       Generally we build the OptionRom by command EfiRom .exe Ce <EFIFile> -f <VID> -I <DID> -p Co <ImgFile>. Is that right?

 

Best Regards

Zhaowei Qin

 


From: Dong, Guo [mailto:guo.dong@intel.com]
Sent: 2014
33 12:41
To: edk2-devel@lists.sourceforge.net
Subject: Re: [edk2] Can't load signed UEFI Option Rom when enable secure boot

 

 

Hi Zhaowei,

 

Are you using latest EfiRom tool?  We ever fixed an issue in EfiRom for uncompressed singed ROM image.

If you are generating a ROM file with -e parameter which indicate the ROM file will not be compressed, you can also try to use -ec parameter to generate a compressed ROM file with your current EfiRom tool.

 

Thanks,

Guo

From: Zhaowei Qin [mailto:zwqin@marvell.com]
Sent: Monday, March 03, 2014 11:22 AM
To: edk2-devel@lists.sourceforge.net
Subject: [edk2] Can't load signed UEFI Option Rom when enable secure boot

 

Hi All

 

We are working on the UEFI Option Rom under Secure Boot, and encounter the problem exactly like below mail:

https://www.mail-archive.com/edk2-devel@lists.sourceforge.net/msg03787.html

We also find the .efi file can be successfully loaded under UEFI Shell, but after convert it to Option Rom by tool EFIROM.exe , it cant work.

Is there any one can help us on this problem?

Thanks a lot~

 

Best Regards

Zhaowei Qin