[edk2] compiled UnixPkg with Ubuntu 11.10

Subject: [edk2] compiled UnixPkg with Ubuntu 11.10

From: <TigerLiu@viatech.com.cn>

To: <edk2-devel@lists.sourceforge.net>

Date: 2011-11-15 23:14:03

Hi, All:

I tried to compile UnixPkg in Ubuntu 11.10 x64 version OS.

I used gcc-4.4 as the default compiler, not use gcc-4.6 default installed by Ubuntu 11.10 .

But found SecMain depended on /usr/X11R6/lib/ , and it displays:

/usr/bin/ld : cannot find –lXext

/usr/bin/ld : cannot find –lX11

 

I googled some information:

X11R6 has been obsolete for quite a while; that is why it isn't part of Ubuntu 9.10.

There is a major compatibility issue between X11R6 and the present X11 version. The two versions behave very differently and are not compatible with each other. Additionally, there could be a graphics driver issue because the drivers had to change a lot in order to work with X windows so today's drivers do not work with X11R6.

 

So, anyone has compiled UnixPkg in Ubuntu 11.10 successfully?

 

Best wishes,