[Edk2 Dev] Trouble building the TOT tools

Subject: [Edk2 Dev] Trouble building the TOT tools

From: "Andrew J. Fish" <afish@apple.com>

To: dev@edk2.tianocore.org

Date: 2008-12-05 01:40:14

I was trying to test out the new build feature Javen mentioned that  
was checked into r6828. Given we don't only run on Windows I had to  
try and merge the python and C tools (TOT from the BaseTools project)  
into our branch. After I did this VFR compiles started failing, so I  
went to back and tried to build the tools on Windows.

When I try on Windows I can not rebuild the tools. Here is what I did,  
and what happened.

pulled BaseTools to c:\work\BaseTools
pulled edk2 to c:\work\edk2
cd c:\work\edk2
edksetup.bat
cd c:\work\BaseTools
set BASE_TOOLS_PATH=c:\work\BaseTools
set PYTHON_FREEZER_PATH=c:\cx_Freeze-3.0.3
toolsetup.bat

nmake clean
...
NMAKE: fatal error U1073: don't know how to make 'clean'
Stop.
Error while makeing Source\Python

nmake
...
VfrSyntax.g(1091) : warning: predicate: LT(i) missing, bad, or with  
i=0; assuming i=1
VfrSyntax.g(1096) : warning: predicate: LT(i) missing, bad, or with  
i=0; assuming i=1
'dlg' is not recognized as an internal or external command,
operable program or batch file.
NMAKE : fatal error U1077: 'dlg' : return code '0x1'
Stop.
Error while making VfrCompile!
NMAKE : fatal error U1077: 'Makefiles\NmakeSubdirs.bat' : return code  
'0x1'
Stop.
Error while making Source\C
NMAKE : fatal error U1077: 'Source\C\Makefiles\NmakeSubdirs.bat' :  
return code '0x1'
Stop.


Am I doing something wrong, or is there an issue with what is checked  
in the BaseTools project.


Andrew Fish
afish@apple.com
Work iPhone: 360-259-7562

------------------------------------------------------
https://edk2.tianocore.org/ds/viewMessage.do?dsForumId=135&dsMessageId=33267

To unsubscribe from this discussion, please e-mail [unsubscribeURL]