[EDK DEV] EDK build error

Subject: [EDK DEV] EDK build error

From: ktckd <ktckd9@gmail.com>

To: dev@edk.tianocore.org

Date: 2008-07-31 17:04:24

Yes that did help after I have included BUILD_THREAD_NUMBER. Thank you Laurie and Hot
Content-Type: multipart/alternative;
	boundary="----_=_NextPart_001_01C8F2AC.26F4B1FA"
Date: Thu, 31 Jul 2008 09:24:17 +0800
From: Tian, Hot <hot.tian@intel.com>
Subject: [EDK DEV] EDK build error

>From the error message, seems BUILD_THREAD_NUMBER is not defined. Please check your platform Config.env, there should have BUILD_THREAD_NUMBER definitions:

BUILD_THREAD_NUMBER            = 2

 

If the BUILD_THREAD_NUMBER is not defined, the following line in platform Makefile:

$(PROCESSDSC) $(COMMON_PROCESSDSC_OPTIONS) -n $(BUILD_THREAD_NUMBER) $(PROJECT_NAME).dsc

will become

$(PROCESSDSC) $(COMMON_PROCESSDSC_OPTIONS) -n $(PROJECT_NAME).dsc

which will produce your error message.

 

Thanks,

Hot

 

The content of this message is my personal opinion only and although I am an employee of Intel, the statements I make here in no way represent Intel's position on the issue, nor am I authorized to speak on behalf of Intel on this matter.

 

________________________________

From: Jarlstrom, Laurie [mailto:laurie.jarlstrom@intel.com] 
Sent: 2008年7月31日 1:49
To: dev@edk.tianocore.org
Subject: RE: [EDK DEV] EDK build error

 

Did you make the following change in Edk\Sample\Platform\Nt32\Build\config.env

 

USE_VC8                        = YES

 

This is needed for VC8

 

thanks,

Laurie

 

laurie.jarlstrom@intel.com

EFI / Framework Technical 

Marketing Engineering Team

(503) 712-9395

________________________________

From: ktckd [mailto:ktckd9@gmail.com] 
Sent: Wednesday, July 30, 2008 8:20 AM
To: dev@edk.tianocore.org
Subject: [EDK DEV] EDK build error

 

I see the following errors when I try to build the EDK. I currently have Visual Studio 2005 (VC8), WINDDK and Microsoft Platform SDK for Windows Server 2003 R2 installed on my computer

 

ProcessDsc : error E0000: -n : input thread number should not be Nt32.dsc
NMAKE : fatal error U1077: 'C:\EDK\Sample\Platform\Nt32\Build\Tools\ProcessDsc.EXE' : return code '0x2'
Stop.

 

Can some one please suggest where am I going wrong? Thanks